Clowns in the Browser! (BETA)

Update Flash: Version 11.4 or better required!

Get Adobe Flash player

Share the Clowns!

Feedback

The browser version of Clowns in the Face is under development and currently requires Flash Player 11.4 or better, so make sure you have that! If you do have Flash 11.4 or better and the game doesn't work, please send your error report to flashclowns@10tons.com with as many details as possible such as your operating system and browser info.

Get Tennis in your pocket!

  • Meet six different Explodz-addicted maniacs
  • More than 100 levels
  • The complete ad-free in-the-face experience

Can't see your platform? Click here for more.
  • Defeat the clown horde!
  • More than 50 levels
  • Remove ads in-app purchase available

More Info

Story of Pete Pagassi

Follow & Contact


For more information contact us at prcontact@10tons.com